Saturday, July 9, 2011

PandaBoard Display Resolution

I wanted to return to the persistent-MAC-address problem and compare Fedora vs Ubuntu, so I swapped SD cards to Ubuntu and powered up the PandaBoard.  To my surprise, Ubuntu set the display resolution to 640x480.  This Samsung 2233SW monitor supports 1920x1080, so why is it so low?  I checked the Monitor Preferences and it only listed 640x480 as an option, and I fired up a terminal and 'xrand -q' reported the same.  I know the last time I booted into Ubuntu in May, it was much higher than 640x480.  What changed?

I tried adding a new mode with 'xrandr  --new-mode ...' but that didn't work.

I found the Omappedia Bootargs for Enabling Display page and tried modifying my /boot/boot.script (and running flash-kernel) to add omapfb.mode=dvi:1920x1080MR-24@60 to the kernel command line arguments, but that didn't work either.

A few hours and many unsuccessful attempts later, I looked around the room and saw an older Dell 1707FPc monitor sitting in the corner.  Maybe I was using that monitor in May?  It only supports 1280x1024, so maybe it will work better?  I cleaned up my boot.script and swapped monitors and voila, it came up with 1280x1024!

I guess the PandaBoard doesn't like this Samsung display for some reason.


  1. Which dell monitor did you use? The reason why I am asking is because I myself am having the same problem with my pandaboard. I am currently running Ubuntu-Netbook 10.10 and plugging in my dell 1905fp monitor via the hdmi port (not the second "dvid-d" port cause that doesn't even work) via a hdmi to dvi-d cable except that the only resolution I can set with the pandaboard is 640 by 480.

  2. I have a Dell 1707FPc which the PandaBoard seems to like. I'm also using an HDMI-to-DVI-D cable and it works correctly at 1280x1024.

    My Samsung is a 2233SW and the PandaBoard only drives it at 640x480.

  3. seems to work with ubuntu oneiric (alpha 3 today).